Troubleshooting: Missing Persona Bar

  • Platform
  • Evoq Content
  • Evoq Engage

Symptom

Persona Bar does not load.

Possible Cause

The site files are located on the root drive rather than inside a folder.

Solution

  1. Move the website contents to a folder.
    1. Create a new folder within the drive. The directory for websites is usually in C:\inetpub\wwwroot\yourwebsitefolder.
    2. Apply IIS permissions to this new folder for your website.
    3. Move the DNN website files to the new folder.
    4. In IIS Manager, change the website's physical path to point to this new folder.
  2. In IIS Manager, restart your website.

    1. Go to Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.

    2. In the Actions panel on the right, click/tap Manage Server > Restart.


      IIS Manager - Restart

      Tip: Remember to update your DNS with your new server’s IP address.

Possible Cause

The web.config file is missing the correct assembly binding.

Solution

  1. Access the web.config file.
  2. Look for the assemblyIdentity node.
    
    assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed"
    						
  3. In the assemblyIdentity node, replace the bindingRedirect tag with the following:

    
    bindingRedirect oldVersion="0.0.0.0-32767.32767.32767.32767" newVersion="7.0.0.0"
    						
  4. In IIS Manager, restart your website.

    1. Go to Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.

    2. In the Actions panel on the right, click/tap Manage Server > Restart.


      IIS Manager - Restart

      Tip: Remember to update your DNS with your new server’s IP address.